码迷,mamicode.com
首页 > 其他好文 > 详细

1058. A+B in Hogwarts (20)

时间:2016-08-01 11:57:28      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28


#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int a,b,c,d,e,f,g=0,h=0,i;
scanf("%d.%d.%d %d.%d.%d",&a,&b,&c,&d,&e,&f);;
i=c+f;
h+=i/29;
i=i%29;

h+=b+e;
g+=h/17;
h=h%17;

g+=a+d;
// g%=10000001;

printf("%d.%d.%d\n",g,h,i);
return 0;
}

1058. A+B in Hogwarts (20)

标签:

原文地址:http://www.cnblogs.com/clanguageweaver/p/5724989.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!