码迷,mamicode.com
首页 > 其他好文 > 详细

杭电oj~1005 简单的找周期

时间:2016-08-01 22:41:45      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153132    Accepted Submission(s): 37335


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5
 

 

Author
CHEN, Shunbao
 

 

Source
 

 

#include<stdio.h>
int fun(int,int,int );
int main()
{
    int a,b;
    long long int n;
while(scanf("%d %d %lld",&a,&b,&n)!=EOF&&(a||b||n))
{
    int arr[50]={1,1};
    for(int i=2;i<=48;i++)
    arr[i]=(a*arr[i-1]+b*arr[i-2])%7;
    if(n%49==0) printf("%d",arr[48]);
    else
        printf("%d\n",arr[n%49-1]);
}
return 0;

}

  

 

周期是7*7==49~yeah!

周期递归做会超时~毕竟n的规模是10^8,所以时间复杂度必须是O(n)!!!!!

 

杭电oj~1005 简单的找周期

标签:

原文地址:http://www.cnblogs.com/hellohacker/p/5727478.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!