码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--大数取模--HDOJ 1212--Big Number--水

时间:2016-08-02 17:07:56      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ题目地址:传送门


Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7350    Accepted Submission(s): 5079


Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521



import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
   public static void main(String[] args) {
	    Scanner cin= new Scanner(System.in); 
	    while(cin.hasNext()){
	    	BigInteger a=cin.nextBigInteger();
	    	BigInteger b=cin.nextBigInteger();
	    	BigInteger c= a.mod(b);
	    	System.out.println(c.toString());
	    }
   }
}

   
   


ACM--大数取模--HDOJ 1212--Big Number--水

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/52094885

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!