码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1711 Number Sequence kmp应用

时间:2016-08-02 23:40:20      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1711

 

题目:

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

 

Sample Output
6 -1
 

 思路:裸的kmp应用,直接用kmp就好了,就当练手

代码:

#include <bits/stdc++.h>
#define PB push_back
#define MP make_pair
using namespace std;
typedef long long LL;
typedef pair<int,int> PII;
#define PI acos((double)-1)
#define E exp(double(1))
#define K 1000000+9
int n,m;
int nt[K],a[K],b[K];
void kmp_next(void)
{
    memset(nt,0,sizeof(nt));
    for(int i=1,j=0;i<m;i++)
    {
        while(j&&b[i]!=b[j])j=nt[j-1];
        if(b[i]==b[j])j++;
        nt[i]=j;
    }
}
int kmp(void)
{
    if(m>n)return -1;
    kmp_next();
    for(int i=0,j=0;i<n;i++)
    {
        while(j&&a[i]!=b[j])j=nt[j-1];
        if(a[i]==b[j])j++;
        if(j==m)
            return i-m+2;
    }
    return -1;
}
int main(void)
{
    int t;cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
        printf("%d\n",kmp());
    }

    return 0;
}

 

hdu1711 Number Sequence kmp应用

标签:

原文地址:http://www.cnblogs.com/weeping/p/5731036.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!