码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1250 树形DP

时间:2014-08-07 22:50:25      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

Anniversary party
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status
Appoint description: 

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings. 
 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output

Output should contain the maximal sum of guests‘ ratings. 
 

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output

5
 

输入: 

输入n个结点,接下去的n行,表示1-n的每个结点分别具有的活跃值,在接下来去的n-1行,输入a,b,表示b是a的上司

输出:

由于直接有上司和下属关系的两个人不能同时参加party, 求出能让party活跃值最大的方案(求出最大的活跃值即可).

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;

const int maxn=6005;
vector<int> v[maxn];
int value[maxn],in[maxn],dp[maxn][2];
inline int max(int a,int b){return a>b?a:b;}
void dfs(int id)
{
    dp[id][0]=0;dp[id][1]=value[id];
    for(int i=0;i<v[id].size();i++)
    {
        int u=v[id][i];
        dfs(u);
        dp[id][0]+=max(dp[u][0],dp[u][1]);
        dp[id][1]+=dp[u][0];
    }
}
int main()
{
    int n,a,b,i,ans;
    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++) v[i].clear();
        for(i=1;i<=n;i++) scanf("%d",&value[i]);
        memset(in,0,sizeof(in));
        while(scanf("%d%d",&a,&b),a+b)
        {
            v[b].push_back(a);in[a]++;
        }
        memset(dp,0,sizeof(dp));
        ans=0;
        for(i=1;i<=n;i++)
            if(!in[i])
            {
                dfs(i);
                ans+=max(dp[i][0],dp[i][1]);
            }
        printf("%d\n",ans);
    }
    return 0;
}

 

hdu 1250 树形DP,布布扣,bubuko.com

hdu 1250 树形DP

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/xiong-/p/3898133.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!