标签:
Description
Input
Output
Sample Input
2 1 8 4 4 7
Sample Output
0 1 0
分析:此题自己想了很久,也有点思路但是呢就是觉得确了点东西,就是做不出来。只要谁面对奇异局势谁就一定输,前面简单的奇异局势有(1,2)(3,5)(4,7)(5,9)(6,11)(7,13)。。。。
我们现在要做的就是判断什么是奇异局势,用代码表示出来,还有就是将非奇异局势变为奇异局势。黄金公式:a=(k*(1-sqrt(5))/2).
AC代码:
#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
if(n<m)
swap(n,m);
int k=n-m;
int a=(k*(1+sqrt(5.0))/2);
if(a==m) printf("0\n");
else printf("1\n");
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/lbyj/p/5738251.html