码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1160 Post Office

时间:2014-08-07 23:08:15      阅读:307      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   

N个数到一个数的距离和最小,这个数一定是他们的中位数。

dp[i][j]=前i个点,j个office的距离。

dp[i][j]=min(dp[k-1][j-1]+w[k][i])    w[k][i]是k..i 修一个office的距离。



Post Office
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15687   Accepted: 8503

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source

[Submit]   [Go Back]   [Status]   [Discuss]






#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=500;
const int INF=0x3f3f3f3f;

int dp[maxn][maxn/10],w[maxn][maxn];
int n,m,a[maxn];

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
	for(int i=1;i<=n;i++)
	{
		scanf("%d",a+i);
	}
	memset(w,63,sizeof(w));
	for(int i=1;i<=n;i++)	
	{
		for(int j=i;j<=n;j++)
		{
			int mid=(i+j)/2,temp=0;
			for(int k=i;k<=j;k++)
			{
				temp+=abs(a[k]-a[mid]);
			}
			w[i][j]=temp;
		}
	}
	memset(dp,63,sizeof(dp));
	for(int i=1;i<=n;i++)
	{
		dp[i][1]=w[1][i];
	}
	for(int i=2;i<=n;i++)
	{
		for(int j=2;j<=m;j++)
		{
			if(j>=i)
			{
				dp[i][j]=0;
				continue;
			}
			for(int k=1;k<i;k++)
			{
				dp[i][j]=min(dp[i][j],dp[k][j-1]+w[k+1][i]);
			}
		}
	}
	printf("%d\n",dp[n][m]);
}
	return 0;
}



POJ 1160 Post Office,布布扣,bubuko.com

POJ 1160 Post Office

标签:des   style   http   color   os   io   strong   for   

原文地址:http://blog.csdn.net/ck_boss/article/details/38426115

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!