码迷,mamicode.com
首页 > 其他好文 > 详细

hdu---1698--Just a Hook

时间:2016-08-04 22:51:26      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 27864    Accepted Submission(s): 13831

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
技术分享
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1. For each silver stick, the value is 2. For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations. You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1 10 2 1 5 2 5 9 3
 

 

Sample Output
Case 1: The total value of the hook is 24.
 
Source
 
Recommend
wangye
 
//不同的是不在原有的基础上增加,更新区间的数
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#define maxn 200007
#define INF 0x3f3f3f3f
typedef long long LL;
using namespace std;
#define lson rt<<1
#define rson rt<<1|1

struct node
{
    int l, r, s, e;
} tree[maxn<<2];

void pushup(int rt)
{
    tree[rt].s=tree[lson].s+tree[rson].s;
}
void build(int l, int r, int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].s=1;///将初始的节点和都赋值为1
    tree[rt].e=0;
    if(l==r)
        return;

    int mid=(l+r)>>1;
    build(l, mid, lson);
    build(mid+1, r, rson);

    pushup(rt);
}

void pushdown(int rt, int m)
{
    if(tree[rt].e)
    {
        tree[lson].e=tree[rt].e;
        tree[rson].e=tree[rt].e;
        tree[lson].s=tree[rt].e*(m-(m>>1));
        tree[rson].s=tree[rt].e*(m>>1);

        tree[rt].e=0;
    }
}
void update(int l, int r, int c, int rt)///l,r表示操作区间,rt表示当前节点编号
{
    if(l<=tree[rt].l&&tree[rt].r<=r)///如果本区间完全在操作区间[L,R]以内  
    {
        tree[rt].e=c;///标记节点
        tree[rt].s=c*(tree[rt].r-tree[rt].l+1);///更新数字和,向上保持正确
        return;
    }
    pushdown(rt, tree[rt].r-tree[rt].l+1);///下推标记
    
    int mid=(tree[rt].l+tree[rt].r)>>1;
    
    ///这里判断左右子树跟[L,R]有无交集,有交集才递归 
    if(l<=mid)
        update(l, r, c, lson);
    if(mid<r)
        update(l, r, c, rson);
    pushup(rt);///更新本节点信息 
}
int main()
{
    int T, cas=1;
    scanf("%d", &T);

    while(T--)
    {
        int n, q;
        scanf("%d%d", &n, &q);
        build(1, n, 1);
        int a, b, c;
        for(int i=1; i<=q; i++)
        {
            scanf("%d%d%d", &a, &b, &c);
            update(a, b, c, 1);
        }
        printf("Case %d: The total value of the hook is %d.\n", cas++, tree[1].s);
    }
    return 0;
}

 

 

hdu---1698--Just a Hook

标签:

原文地址:http://www.cnblogs.com/w-y-1/p/5738418.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!