码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3032 Nim or not Nim?(SG函数)

时间:2016-08-05 06:39:59      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1710    Accepted Submission(s): 845


Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

Sample Input
2 3 2 2 3 2 3 3
 

Sample Output
Alice Bob
 

Source

 

题意:nim博弈的变形,n堆石头,每次可以在一堆中取任意数目的石头,或者把它分成两堆不为0的堆;最后取完的获胜。

分析:一步一步的推SG值...

          很明显sg[0]=0, sg[1]=1;

          然后状态2的后继有:0,1和(1, 1), 他们的sg值为0,1,0;所以sg[2]=2;

          然后状态3的后继有:0,1,2和(1, 2), 他们的sg值为0,1,2,3;所以sg[3]=4;

          然后状态4的后继有:0,1,2,3、(1, 3)和(2, 2), 他们的sg值为0,1,2,4,5,0;所以sg[4]=3;

          ..........

          最后根据所推出的sg值,得到:对于所有的k >= 0,有 sg( 4k+1 ) = 4k+1; sg( 4k+2 ) = 4k+2;     sg( 4k+3 )= 4k+4; sg( 4k+4 ) = 4k+3

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 1e9;
const int MOD = 1e9+7;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define N 1000010
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int main()
{
    int T,n,x;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int ans = 0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&x);
            if(x%4==0) ans ^= (x-1);
            else if(x%4==1||x%4==2) ans ^= x;
            else ans ^= (x+1);
        }
        if(ans) cout<<"Alice"<<endl;
        else cout<<"Bob"<<endl;
    }
    return 0;
}


 


hdu3032 Nim or not Nim?(SG函数)

标签:

原文地址:http://blog.csdn.net/d_x_d/article/details/52124418

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!