码迷,mamicode.com
首页 > 其他好文 > 详细

ACM--猫鼠交易--HDOJ 1009--FatMouse' Trade--贪心

时间:2016-08-06 13:08:17      阅读:498      评论:0      收藏:0      [点我收藏+]

标签:


HDOJ题目地址:传送门



FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67028    Accepted Submission(s): 22794


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct node{
    int J;
    int F;
}Node[1100];
bool cmp(node a,node b){
    return 1.0*a.J/a.F>1.0*b.J/b.F;
}
int main(){
    int m,n;
    while(scanf("%d%d",&m,&n)&&m!=-1&&n!=-1){
        double result=0.0,java=m-0.0;
        int temp=0;
        while(temp<n){
           scanf("%d%d",&Node[temp].J,&Node[temp].F);
           temp++;
        }
        sort(Node,Node+n,cmp);
        for(int i=0;i<n;i++){
            if(java>Node[i].F){
                result+=Node[i].J;
                java-=Node[i].F;
            }else{
                result+=(Node[i].J*(java/Node[i].F));
                break;
            }
        }
       printf("%.3lf\n",result);
    }
}






ACM--猫鼠交易--HDOJ 1009--FatMouse' Trade--贪心

标签:

原文地址:http://blog.csdn.net/qq_26891045/article/details/52135492

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!