码迷,mamicode.com
首页 > 其他好文 > 详细

poj1704 Georgia and Bob(阶梯博弈)

时间:2016-08-06 16:07:28      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:

Georgia and Bob
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9291   Accepted: 3021

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 
技术分享

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise ‘Not sure‘.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source


【题意】

从左到右有一排石子,给出石子所在的位置。规定每个石子只能向左移动,且不能跨过前面的石子。最左边的石子最多只能移动到1位置。每次选择一个石子按规则向左移动,问先手是否能赢。

【分析】

我们把棋子按位置升序排列后,从后往前把他们两两绑定成一对。如果总个数是奇数,就把最前面一个和边界(位置为0)绑定。

在同一对棋子中,如果对手移动前一个,你总能对后一个移动相同的步数,所以一对棋子的前一个和前一对棋子的后一个之间有多少个空位置对最终的结果是没有影响的。

于是我们只需要考虑同一对的两个棋子之间有多少空位。

这样一来就成了N堆取石子游戏了.


Ps:对于阶梯博弈,我的理解就是,两两抱团,奇数就把第一个单独提出,其余的两两抱团,再来做nim。

 

#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 1e9;
const int MOD = 1e9+7;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define N 50010
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int n,k;
int s[1010];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&s[i]);
        sort(s+1, s+n+1);
        int ans;
        if(n%2 == 0)
        {
            ans = s[2]-s[1]-1;
            for(int i=4; i<=n; i+=2) ans ^= (s[i]-s[i-1]-1);
            if(ans == 0) cout<<"Bob will win"<<endl;
            else cout<<"Georgia will win"<<endl;
        }
        else
        {
            ans = s[1]-1;
            for(int i=3; i<=n; i+=2) ans ^= (s[i]-s[i-1]-1);
            if(ans == 0) cout<<"Bob will win"<<endl;
            else cout<<"Georgia will win"<<endl;
        }
    }
    return 0;
}


 

poj1704 Georgia and Bob(阶梯博弈)

标签:

原文地址:http://blog.csdn.net/d_x_d/article/details/52136560

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!