标签:
Description
Input
Output
Sample Input
6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
Sample Output
success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2
题意:有一只蜗牛在井底,问你他是否能够离开井。基础题
H:井的高度
U:每天白天爬的高度
D:每天晚上下滑的高度
F:蜗牛的疲劳期,每天少爬U*F/100
注意:
1、蜗牛每天爬的距离都比前一天少
2、蜗牛每天爬的距离总是要大于0
3、函数类型最好用double
4、当蜗牛爬行的总路程大于井的高度时就成功了,当蜗牛下滑之后的高度小于0就失败
心得:感觉自己对for循环和break的一些用法有些模糊不清了,恩,还是有收获的
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
double a,b,c,d;
double sum,s;
int i;
while(scanf("%lf %lf %lf %lf",&a,&b,&c,&d),a)
{
s=b;
i=0;
sum=0;
//if(a==0) break;
while(1)
{
i++;
if(s>0) sum=sum+s;
if(sum>a) break;
sum=sum-c;
if(sum<0) break;
s=s-(d/100)*b;
}
if(sum>a) printf("success on day %d\n",i);
else printf("failure on day %d\n",i) ;
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/lbyj/p/5744289.html