码迷,mamicode.com
首页 > 其他好文 > 详细

Price List

时间:2016-08-07 10:53:03      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 296    Accepted Submission(s): 192


Problem Description
There are n技术分享 shops numbered with successive integers from 1技术分享 to n技术分享 in Byteland. Every shop sells only one kind of goods, and the price of the i技术分享 -th shop‘s goods is v技术分享i技术分享技术分享 .

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar‘s poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn‘t used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

 

Input
The first line of the input contains an integer T技术分享 (1T10)技术分享 , denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m技术分享 (1n,m100000)技术分享 , denoting the number of shops and the number of records on Byteasar‘s account book.

The second line of the input contains n技术分享 integers v技术分享1技术分享,v技术分享2技术分享,...,v技术分享n技术分享技术分享 (1v技术分享i技术分享100000)技术分享 , denoting the price of the i技术分享 -th shop‘s goods.

Each of the next m技术分享 lines contains an integer q技术分享 (0q10技术分享18技术分享)技术分享 , denoting each number on Byteasar‘s account book.
 

 

Output
For each test case, print a line with m技术分享 characters. If the i技术分享 -th number is sure to be strictly larger than the actual value, then the i技术分享 -th character should be ‘1‘. Otherwise, it should be ‘0‘.
 

 

Sample Input
1 3 3 2 5 4 1 7 10000
 

 

Sample Output
001
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5808 5807 5806 5805 5804 
 
唉,昨晚只做出来一个题。
 
代码:
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int t;
    int n,m;
    int v=0;;
    int sum=0;
    int jilu[100005];
    int jieguo[100005];
    scanf("%d",&t);
    while(t--){
        sum=0;
        scanf("%d %d",&n,&m);
        for(int i=0;i<n;i++){
            scanf("%d",&v);
            sum+=v;
        }
        for(int j=0;j<m;j++){
            scanf("%d",&jilu[j]);
        }
        for(int j=0;j<m;j++){
            if(jilu[j]>sum){
                printf("1");
            }else{
                printf("0");
            }
        }
        printf("\n");


    }
    return 0;
}

 

Price List

标签:

原文地址:http://www.cnblogs.com/TWS-YIFEI/p/5745643.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!