码迷,mamicode.com
首页 > 其他好文 > 详细

NanoApe Loves Sequence-待解决

时间:2016-08-07 10:59:54      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 440    Accepted Submission(s): 205


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n技术分享 numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F技术分享 .

Now he wants to know the expected value of F技术分享 , if he deleted each number with equal probability.
 

 

Input
The first line of the input contains an integer T技术分享 , denoting the number of test cases.

In each test case, the first line of the input contains an integer n技术分享 , denoting the length of the original sequence.

The second line of the input contains n技术分享 integers A技术分享1技术分享,A技术分享2技术分享,...,A技术分享n技术分享技术分享 , denoting the elements of the sequence.

1T10, 3n100000, 1A技术分享i技术分享10技术分享9技术分享技术分享
 

 

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n技术分享 .
 

 

Sample Input
1 4 1 2 3 4
 

 

Sample Output
6
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5808 5807 5806 5805 5804 
 
#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int main()
{
    int t;
    int n;
    int cha=0;
    int cha2=0;
    int a[100005]={0};
    int maxx1;
    int first;
    int maxx2;
    int second;
    int maxx3;
    int third;
    int sum=0;
    scanf("%d",&t);
    for(int z=0;z<t;z++){
        sum=0;
        maxx1=0;
        maxx2=0;
        maxx3=0;
        scanf("%d",&n);

        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(i!=0){
                cha=abs(a[i]-a[i-1]);
                if(maxx1<cha){
                    maxx1=cha;
                    first=i;
                }
            }
        }

        for(int i=1;i<n;i++){
            cha=abs(a[i]-a[i-1]);
            if(maxx2<cha){
                if(maxx2<=maxx1){
                    if(i==first){
                        continue;
                    }else{
                        maxx2=cha;
                        second=i;
                    }
                }
            }
        }

        for(int i=1;i<n;i++){
            cha=abs(a[i]-a[i-1]);
            if(maxx2<cha){
                if(maxx3<=maxx1&&maxx3<=maxx2){
                    if(i==first||i==second){
                        continue;
                    }else{
                        maxx3=cha;
                        third=i;
                    }
                }
            }
        }

        for(int i=1;i<n-1;i++){
            cha2=abs(a[i+1]-a[i-1]);
            if(maxx1<=cha2){
                sum+=cha2;
            }
            if(maxx1>cha2){
                if(i==first&&i+1==second||i==second&&i+1==first){
                    if(maxx3!=0){
                        if(maxx3>=cha2){
                            sum+=maxx3;
                        }else{
                            sum+=cha2;
                        }

                    }else{
                        sum+=cha2;
                    }

                }
                if(i==first||i==first-1){
                    if(cha2<=maxx2){
                        sum+=maxx2;
                    }else{
                        sum+=cha2;
                    }
                }else{
                    sum+=maxx1;
                }

            }
        }
        if(first==1){
            sum+=maxx2;
            sum+=maxx1;
        }
        if(first==n-1){
            sum+=maxx2;
            sum+=maxx1;
        }
        if(first!=1&&first!=n-1){
            sum+=(2*maxx1);
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

 
 

NanoApe Loves Sequence-待解决

标签:

原文地址:http://www.cnblogs.com/TWS-YIFEI/p/5745639.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!