码迷,mamicode.com
首页 > 其他好文 > 详细

Subsequence 尺取法

时间:2016-08-07 12:11:37      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

Subsequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12304   Accepted: 5165

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

 不断更新l,r值,当sum < s 时程序结束。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int maxn = 100010;
typedef long long ll;
int t,n,ss;
int s[maxn];
int main()
{
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&ss);
        for(int i =0;i<n;i++) scanf("%d",s+i);
        int l=0,r=0,sum=0,res=maxn;
        while(1){
            while(r<n&&sum<ss){
                sum+=s[r++];
            }
            if(sum<ss) break;
            res=min(res,r-l);
            sum-=s[l++];
        }
        if(res==maxn) printf("0\n");
        else  printf("%d\n",res);
    }
}

 

Subsequence 尺取法

标签:

原文地址:http://www.cnblogs.com/acmtime/p/5745840.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!