码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3048 Max Factor (筛素数)

时间:2016-08-07 12:29:04      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:

Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows. 

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not). 

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38


题意:给你n个数,让你求出其中质因数最大的数
思路:这是筛素数的思想,在筛素数的时候,记录每个数对应的最大质因数,这样在访问该数的时候可以以o(1)的复杂度找到它所对应的最大质因数。再加上贪心的想法,在每次访问的时候找到当前最大质因数,并且记录该数。

代码如下:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;


const int N=20010;
bool a[N];
int ans[N];


void isprime() //作用:找到每个数所对应的最大素数
{
  int k=0;
  memset(a,true,sizeof(a));
  a[0]=a[1]=false;
  for(int i=2;i<N;i++)
  {
    if(a[i])
    {
      ans[i]=i;
      for(int j=i*2;j<N;j+=i)
      ans[j]=i;

      a[j]=false;
    }
  }
}


int main()
{
  isprime();
  int m;
  while(~scanf("%d",&m))
  {
    int maxn=-N;
    int x=-N;
    while(m--)
    {
      int a;
      scanf("%d",&a);
      if(ans[a]>maxn)
      {
        maxn=ans[a];
        x=a;
      }
    }
    printf("%d\n",x);
  }
  return 0;
}

 

POJ 3048 Max Factor (筛素数)

标签:

原文地址:http://www.cnblogs.com/Amidgece/p/5745739.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!