标签:
Description
Input
Output
Sample Input
4 36 38 40 42
Sample Output
38
题意:给你n个数,让你求出其中质因数最大的数
思路:这是筛素数的思想,在筛素数的时候,记录每个数对应的最大质因数,这样在访问该数的时候可以以o(1)的复杂度找到它所对应的最大质因数。再加上贪心的想法,在每次访问的时候找到当前最大质因数,并且记录该数。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N=20010;
bool a[N];
int ans[N];
void isprime() //作用:找到每个数所对应的最大素数
{
int k=0;
memset(a,true,sizeof(a));
a[0]=a[1]=false;
for(int i=2;i<N;i++)
{
if(a[i])
{
ans[i]=i;
for(int j=i*2;j<N;j+=i)
ans[j]=i;
a[j]=false;
}
}
}
int main()
{
isprime();
int m;
while(~scanf("%d",&m))
{
int maxn=-N;
int x=-N;
while(m--)
{
int a;
scanf("%d",&a);
if(ans[a]>maxn)
{
maxn=ans[a];
x=a;
}
}
printf("%d\n",x);
}
return 0;
}
标签:
原文地址:http://www.cnblogs.com/Amidgece/p/5745739.html