码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5806 NanoApe Loves Sequence Ⅱ

时间:2016-08-07 12:28:54      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 517    Accepted Submission(s): 250


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.
 

 

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

 

Output
For each test case, print a line with one integer, denoting the answer.
 

 

Sample Input
1
7 4 2
4 2 7 7 6 5 1
 
Sample Output
18

求有多少个区间,使得区间内的第k大的值>=m.

 

将不小于m的数看作1,剩下的数看作0,那么只要区间内1的个数不小于k则可行,枚举左端点,右端点可以通过two-pointer求出。

/* ***********************************************
Author        :guanjun
Created Time  :2016/8/7 10:02:54
File Name     :hdu5806.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
    int x,y;
};
struct cmp{
    bool operator()(Node a,Node b){
        if(a.x==b.x) return a.y> b.y;
        return a.x>b.x;
    }
};

bool cmp(int a,int b){
    return a>b;
}
int a[200010];
int sum[200010];
int n,m,k;
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int t;
    cin>>t;
    while(t--){
        scanf("%d%d%d",&n,&m,&k);
        int x;
        sum[0]=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            if(x>=m)a[i]=1;
            else a[i]=0;
            sum[i]=sum[i-1]+a[i];
        }
        ll ans=0;
        int r=1;
        for(int l=1;l<=n;l++){//枚举左端点
            while(r<=n&&sum[r]-sum[l-1]<k)r++;
            if(r>n)break;
            ans+=(n-r+1);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

将不小于mm的数看作11,剩下的数看作00,那么只要区间内11的个数不小于kk则可行,枚举左端点,右端点可以通过two-pointer求出

HDU5806 NanoApe Loves Sequence Ⅱ

标签:

原文地址:http://www.cnblogs.com/pk28/p/5745762.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!