码迷,mamicode.com
首页 > 其他好文 > 详细

hdu---1003---Max Sum

时间:2016-08-08 12:54:16      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=1003

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 216737    Accepted Submission(s): 51087

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

 

Author
Ignatius.L
 

 

Recommend
We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include<vector>
#include<algorithm>
using namespace std;
#define PI 3.1415926

const int maxn=1000007;
const int INF=0x3f3f3f3f;

int a[maxn];
int main()
{
    int T, cas=1, f=0;
    scanf("%d", &T);
    while(T--)
    {
         if(f)
            puts("");///printf("\n");
        int n;
        scanf("%d", &n);
        for(int i=1; i<=n; i++)
            scanf("%d", &a[i]);

        int nows=1, Start=1, End=1;
        int sum, Max;
        sum=Max=a[1];

        for(int i=2; i<=n; i++)
        {
            if(sum+a[i]<a[i])
            {
                sum=a[i];
                nows=i;
            }
            else
                sum+=a[i];

            if(sum>Max)
            {
                Max=sum;
                Start=nows;
                End=i;
            }
        }
        printf("Case %d:\n%d %d %d\n", cas++, Max, Start, End);
        f=1;
    }
    return 0;
}

 

hdu---1003---Max Sum

标签:

原文地址:http://www.cnblogs.com/w-y-1/p/5748644.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!