码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1797 Heavy Transportation【Dijkstra最短路变形】

时间:2016-08-08 14:39:30      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:


Heavy Transportation
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 29682   Accepted: 7919

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo‘s place) to crossing n (the customer‘s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

原题链接:http://poj.org/problem?id=1797

题意:有n个城市,m条道路,每条道路都有一定的承重,问你从1开始到达n的最大承重量(该路线上所有承重量的最小值)。

思路:还是最短路的问题,改变一下判断条件就可以了。

Dijkstra算法AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1005;
int a[maxn][maxn];
bool vis[maxn];
int dis[maxn];
int n;
void Dij()
{
    for(int i=1;i<=n;i++)
    {
        vis[i]=false;
        dis[i]=a[1][i];
    }
    vis[1]=true;
    dis[1]=0;
    for(int i=1;i<=n;i++)
    {
        int p;
        int maxx=0;//此题要找最大的
        for(int j=1;j<=n;j++)
        {
            //关键代码
            if(!vis[j]&&dis[j]>maxx)
                maxx=dis[p=j];
        }
        vis[p]=true;
        for(int j=1;j<=n;j++)
        {
            //关键代码
            if(!vis[j]&&dis[j]<min(a[p][j],dis[p]))
            {
                dis[j]=min(a[p][j],dis[p]);
            }
        }
    }
}
int main()
{
    int T;
    int kase=0;
    cin>>T;
    while(T--)
    {
        int m;
        scanf("%d%d",&n,&m);
        int x,y,z;
        memset(a,0,sizeof(a));//初始化
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z>a[x][y])
                a[x][y]=a[y][x]=z;
        }
        Dij();
        printf("Scenario #%d:\n",++kase);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}


POJ 1797 Heavy Transportation【Dijkstra最短路变形】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52151573

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!