码迷,mamicode.com
首页 > 其他好文 > 详细

poj---1338---Ugly Numbers

时间:2016-08-09 10:45:59      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1338

 

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 22968   Accepted: 10218

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence  1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...  shows the first 10 ugly numbers. By convention, 1 is included.  Given the integer n,write a program to find and print the n‘th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

Source

 
丑数的定义:一个数的素因数只有2, 3,或5.
因此只有这三个数来回的做乘法,按顺序存起来就OL!
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;

const int maxn=1502;
const int INF=0x3f3f3f3f;

int ugly[maxn]= {0, 1};


void Init()
{
    int num2=2, num3=3, num5=5;
    int i, j, k, t;
    i=j=k=1;

    for(int x=2; x<maxn; x++)
    {
        t=min(num2, min(num3, num5));
        ugly[x]=t;

        if(t==num2)
            num2=ugly[++i]*2;

        if(t==num3)
            num3=ugly[++j]*3;

        if(t==num5)
            num5=ugly[++k]*5;
    }
}
int main()
{
    Init();
    int n;

    while(scanf("%d", &n), n)
        printf("%d\n", ugly[n]);
    return 0;
}

 

poj---1338---Ugly Numbers

标签:

原文地址:http://www.cnblogs.com/w-y-1/p/5752065.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!