码迷,mamicode.com
首页 > 其他好文 > 详细

E - IMMEDIATE DECODABILITY

时间:2014-08-08 12:52:26      阅读:267      评论:0      收藏:0      [点我收藏+]

标签:前缀   字符串对比   字典树   

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000 

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable
 

题目大意:

给出多组字符串,判断每组字符串中有没有某个字符串是其它字符串的前缀,如果有输出“Set 数字 is not immediately decodable”,如果没有输出Set 数字 is immediately decodable(其中数字代表第几组),每组的输入以一个单一的字符‘9’结束。
解题思路:

暴力查找,比对。将一组的字符串按字典序排序,然后比对相邻的字符串是否一个是另一个的前缀。

本题还可用字典树解答。

代码如下:C++代码

#include <iostream>
#include <string>
#include<stdio.h>
#include <algorithm>
using namespace std;
string s[20];//储存字符串
int main()
{
	int num=1,i,j,n;
	while(cin>>s[0])
    {
		n=0;
		while(s[n]!="9")
		{
			n++;
			cin>>s[n];
		}
		sort(s,s+n);//按字典序排序字符串
		//判断相邻字符串是否存在前缀
		for(i=0;i<n-1;i++)
		{
			for(j=0;j<s[i].size();j++)
			{
				if(s[i][j]!=s[i+1][j])
					break;
			}
			if(j==s[i].size())
				break;
		}
		if(i<n-1)
			printf("Set %d is not immediately decodable\n",num++);
		else
			printf("Set %d is immediately decodable\n",num++);
	}
	return 0;
}





E - IMMEDIATE DECODABILITY,布布扣,bubuko.com

E - IMMEDIATE DECODABILITY

标签:前缀   字符串对比   字典树   

原文地址:http://blog.csdn.net/yanghuaqings/article/details/38435365

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!