码迷,mamicode.com
首页 > 其他好文 > 详细

1220 数字三角形

时间:2016-08-11 21:03:23      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

 时间限制: 1 s

 空间限制: 128000 KB
 题目等级 : 黄金 Gold
 
 
题目描述 Description

如图所示的数字三角形,从顶部出发,在每一结点可以选择向左走或得向右走,一直走到底层,要求找出一条路径,使路径上的值最大。

技术分享
输入描述 Input Description

第一行是数塔层数N(1<=N<=100)。

第二行起,按数塔图形,有一个或多个的整数,表示该层节点的值,共有N行。

输出描述 Output Description

输出最大值。

样例输入 Sample Input

5

13

11 8

12 7 26

6 14 15 8

12 7 13 24 11

样例输出 Sample Output

86

数据范围及提示 Data Size & Hint
数字三角形
代码:

#include<cstdio>
#include<algorithm>
using namespace std;
bool d;
int b[101][101],n,tot;
int main(){
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++){
for(j=1;j<=i;j++){
scanf("%d",&b[i][j]);
}
}
for(i=n-1;i>=1;i--)
for(j=1;j<=i;j++)
b[i][j]+=max(b[i+1][j],b[i+1][j+1]);
printf("%d\n",b[1][1]);
return 0;
}

思路: 从倒数第二行向上开始推,最后输出f[1][1];(与“数塔”一题差不多)

1220 数字三角形

标签:

原文地址:http://www.cnblogs.com/zhishenduchuang/p/5762403.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!