码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2669 Romantic

时间:2016-08-13 18:14:29      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

Romantic
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

技术分享 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3


分析:ax+by=gcd(a,b)*k,只有k为整数时,才有解,所以当前仅当gcd(a,b)=1时,这道题有解。

当求解出x<0时,利用

(x+b/gcd(a,b),y-a/gcd(a,b) 都是符合条件的解这一性质,找到第一个符合条件的x输出之。

 

技术分享
#include<iostream>
#include<stdio.h>
using namespace std;
long long ext_gcd(long long a,long long  b,long long  *x,long long *y)
{
    if(b==0)
    {
        *x=1;
        *y=0;
        return a;
    }
    long long r = ext_gcd(b,a%b,x,y);
    long long  t = *x;
    *x=*y;
    *y=t - a/b * *y;
    return r;
}
int main()
{

    long long a,b,x,y;
    while(~scanf("%I64d%I64d",&a,&b))
    {
        if(ext_gcd(a,b,&x,&y)==1)
        {
            while(x<0)
            {
                x+=b/1;
                y-=a/1;
            }

            printf("%I64d %I64d\n",x,y);
            continue;
        }
       else printf("sorry\n");
    }
    return 0;
}
View Code

 

hdu 2669 Romantic

标签:

原文地址:http://www.cnblogs.com/superxuezhazha/p/5768443.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!