码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1218 THE DRUNK JAILER【类开灯问题】

时间:2016-08-14 16:21:19      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

THE DRUNK JAILER
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27268   Accepted: 16933

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100

Sample Output

2
10

Source



题意:输入n,n为5-100间的一个数,代表有多少间牢房。刚开始所有房间打开,第1轮2的倍数的房间门翻转(打开的关上,关上的打开),第2轮3的倍数,第3轮4的倍数,......,第n-1轮n的倍数。求最后有几间牢房门是打开的。

和经典的开灯问题差不多,数据不大,可以直接模拟,但也有好方法。

AC代码1:暴力模拟:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    bool a[105];
    int T,n;
    //freopen("data/1218.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>n;
        memset(a,true,sizeof(a));
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(j%i==0)
                    a[j]=!a[j];
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(a[i])
                ans++;
        cout<<ans<<endl;
    }
    return 0;
}

AC代码2:

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
int main()
{
    int T,n;
    //freopen("data/1218.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>n;
        int ans=0;
        for(int i=1;i*i<=n;i++)
            ans++;
        cout<<ans<<endl;
    }
    return 0;
}

AC代码3:大牛代码

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
int main()
{
    int T,n;
    //freopen("data/1218.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>n;
        int ans=(int)sqrt(n*1.0);
        cout<<ans<<endl;
    }
    return 0;
}


HDU 1218 THE DRUNK JAILER【类开灯问题】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52204676

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!