码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5832 A water problem(取模~)—— 2016中国大学生程序设计竞赛 - 网络选拔赛

时间:2016-08-14 19:26:59      阅读:232      评论:0      收藏:0      [点我收藏+]

标签:

传送门

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 60    Accepted Submission(s): 37


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0N), the length of N is up to 10000000.
 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

Sample Input
10001
0
333
 

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO
 

Author
UESTC
 

Source

题目大意:

就是给你一个大数,让你判断是不是 73137 的公倍数。

解题思路:

大数 其实这个题一分析一下,因为 73137 是素数,所以就是对 73?137 取模,然后跑一个循

环就行了,坑的是 cin 会超时,然后 改成 scanf 还超时,等了一会儿又交一遍竟然过了,AC

了!!!

My Code

/**
2016 - 08 - 14 下午
Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const int INF = 1e9+5;
const int MAXN = 1e7+5;
const int MOD = 10001;
const double eps = 1e-7;
const double PI = acos(-1);
using namespace std;
char str[MAXN];
int main()
{

    int cas = 1;
    while(scanf("%s",str)!=-1)
    {
        int len = strlen(str);
        int sum = 0;
        for(int i=0; i<len; i++)
        {
            sum = sum*10;
            sum = (sum+str[i]-‘0‘);
            sum = sum%MOD;
        }
        if(sum == 0)
            printf("Case #%d: YES\n",cas++);
        else
            printf("Case #%d: NO\n",cas++);
    }
    return 0;
}

HDU 5832 A water problem(取模~)—— 2016中国大学生程序设计竞赛 - 网络选拔赛

标签:

原文地址:http://blog.csdn.net/qingshui23/article/details/52205593

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!