码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1300Door Man(欧拉回路)

时间:2016-08-14 23:47:32      阅读:190      评论:0      收藏:0      [点我收藏+]

标签:

                                                           Door Man
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2639   Accepted: 1071

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you:

  1. Always shut open doors behind you immediately after passing through
  2. Never open a closed door
  3. End up in your chambers (room 0) with all doors closed

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:

  1. Start line - A single line, "START M N", where M indicates the butler‘s starting room, and N indicates the number of rooms in the house (1 <= N <= 20).
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors!
  3. End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10
【分析】这一题就是个欧拉回路的判定,很简单,但是输入有点麻烦。
技术分享
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#include<functional>
#define mod 1000000007
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
using namespace std;
typedef long long ll;
const int N=1005;
const int M=150005;
ll power(ll a,int b,ll c){ll ans=1;while(b){if(b%2==1){ans=(ans*a)%c;b--;}b/=2;a=a*a%c;}return ans;}
char str[N];
int n,m,cnt[35];
int main()
{
    while(gets(str)!=NULL){
        if(!strcmp(str,"ENDOFINPUT"))break;
        sscanf(str,"%*s%d%d",&m,&n);
        memset(cnt,0,sizeof(cnt));
        int ans=0;
        for(int i=0;i<n;i++){
            gets(str);
            int k=0,j;
            while(sscanf(str+k,"%d",&j)==1){
                ans++;
                cnt[i]++;
                cnt[j]++;
                while(str[k]&&str[k]== )k++;
                while(str[k]&&str[k]!= )k++;
            }
        }
        gets(str);
        int odd=0,even=0;
        for(int i=0;i<n;i++){
            if(cnt[i]&1)odd++;
            else even++;
        }
        if(!odd&&!m)printf("YES %d\n",ans);
        else if(odd==2&&(cnt[m]&1)&&(cnt[0]&1)&&m)printf("YES %d\n",ans);
        else printf("NO\n");
    }

    return 0;
}
View Code

 

POJ1300Door Man(欧拉回路)

标签:

原文地址:http://www.cnblogs.com/jianrenfang/p/5771225.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!