码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5832 A water problem 大数取余

时间:2016-08-15 22:00:04      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 650    Accepted Submission(s): 333


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.
There is 73 days in Xixi a year and 137 days in Haha a year. 
Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 
Input
There are several test cases(about 5 huge test cases).
For each test, we have a line with an only integer N(0N), the length of N is up to 10000000.
 
Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 
Sample Input
10001
0
333
 
Sample Output
Case #1: YES
Case #2: YES
Case #3: NO
 

Author

UESTC

 Source
 
 
ccpc的网络赛被虐的好惨啊 做完水题其他就下不了手了技术分享
还要加油  
 
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <iomanip>
#include <math.h>
#include <map>
using namespace std;
#define FIN     freopen("input.txt","r",stdin);
#define FOUT    freopen("output.txt","w",stdout);
#define INF     0x3f3f3f3f
#define INFLL   0x3f3f3f3f3f3f3f
#define lson    l,m,rt<<1
#define rson    m+1,r,rt<<1|1
typedef long long LL;
typedef pair<int,int> PII;

const int MAXN = 10000005;

char s[MAXN];

int check(char s[], int mod){
    
    //将数字看成多项式的和  比如12345就是1*10^5+2*10^4+3*10^3+4*10^2+5*10^1
    //先把数求模和分开求再合起来求模结果是一样的
    
    LL sum = 0;
    int len = strlen(s);
    for( int i = 0; i < len ; i++){
        sum = sum*10 + s[i]-48;
        sum %= mod;
    }
    return sum;
}

int main()
{
    //FIN
    int cas = 1;
    while(~scanf("%s", s)){
        if(check(s, 137) == 0 && check(s, 73) == 0)  printf("Case #%d: YES\n",cas++);
        else  printf("Case #%d: NO\n",cas++);
    }

}

  

 

HDU 5832 A water problem 大数取余

标签:

原文地址:http://www.cnblogs.com/Hyouka/p/5774231.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!