码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4763 Theme Section (简单KMP)

时间:2014-08-08 21:22:06      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1184    Accepted Submission(s): 621


Problem Description
It‘s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section‘. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE‘, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a‘ - ‘z‘.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
0 0 1 1 2
 

Source

题意:给定一个字符串,寻找3段字符串使它们完全相等(不能重叠),一个必须从头开始,一个必须以末尾结束。


#include"stdio.h"
#include"string.h"
#define N 1000005
char str[N],s[N];
int next[N],n;
void getnext(int m)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<m)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            if(s[i]!=s[j])
                next[i]=j;
            else
                next[i]=next[j];
        }
        else
            j=next[j];
    }
}
int kmp(int m)   //模式串长度
{
    int i=0,j=0;
    getnext(m);
    while(i<n)
    {
        if(j==-1||str[i]==s[j])
        {
            i++;
            j++;
        }
        else
            j=next[j];
        if(j==m)    
            return 1;     
    }
    return 0;
}
void work(char*s,int m)
{
    int i,j;
    while(m)         //查找第一个字符串和最后一个字符串最大的匹配
    {
        i=0;
        for(j=n-m;j<n;j++)
        {
            if(s[i++]!=str[j])
                break;
        }
        if(j==n)
        {
            if(kmp(m))
                break;
        }
        m--;
    }
    printf("%d\n",m);
}
int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",str);
        n=strlen(str);
        for(i=0;i<n/3;i++)
            s[i]=str[i];
        s[i]='\0';        //第一个字符串长度为I
        work(s,i);
    }
    return 0;
}


hdu 4763 Theme Section (简单KMP),布布扣,bubuko.com

hdu 4763 Theme Section (简单KMP)

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/38444929

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!