码迷,mamicode.com
首页 > 其他好文 > 详细

CSU 1100: 一二三【模拟】

时间:2016-08-16 14:48:41      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:


1100: 一二三

Time Limit: 1 Sec  Memory Limit: 128 MB

Description

你弟弟刚刚学会写英语的一(one)、二(two)和三(three)。他在纸上写了好些一二三,可惜有些字母写错了。已知每个单词最多有一个字母写错了(单词长度肯定不会错),你能认出他写的啥吗?  

Input

第一行为单词的个数(不超过10)。以下每行为一个单词,单词长度正确,且最多有一个字母写错。所有字母都是小写的。 

Output

对于每组测试数据,输出一行,即该单词的阿拉伯数字。输入保证只有一种理解方式。 

Sample Input

3
owe
too
theee

Sample Output

1
2
3

HINT

Source


AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int T;
    char a[5];
    //freopen("data/1010.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>a;
        int len = strlen(a);
        if(len==5)
            cout<<"3"<<endl;
        else if(a[0]=='o')
        {
            if(a[1]=='w'&&a[2]=='o')
                cout<<"2"<<endl;
            else
                cout<<"1"<<endl;
        }
        else
        {
            if(a[1]=='n'&&a[2]=='e')
                cout<<"1"<<endl;
            else
                cout<<"2"<<endl;
        }
    }
    return 0;
}


CSU 1100: 一二三【模拟】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52219893

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!