码迷,mamicode.com
首页 > 其他好文 > 详细

poj3080Blue Jeans

时间:2014-08-09 00:12:16      阅读:356      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

题目链接:

题意是:

给n个字符串然后找出n个字符串里面最长的公共字串。。
这道题目最开始以为是dp,后来又以为是kmp,但是kmp貌似没看到过这么多字符串相匹配的,后来就搜题解,太弱了,只能看别人题解。。
思路是:
首先看数据大小,最多只有10个串,那么把第一个串当作母串,然后逐个去枚举母串中的子串,然后根据字串去其他n-1个DNA序列中检测,看是否这些子串在其他DNA序列中存在,然后把第一个母串中所有的的字串进行枚举,得到所有字符串都满足的最长公共字串,如果存在相同的子串,那么选取字典序最小的那个。。这样这题就已暴力的方式得到了解决。。然后就是找枚举的字串在其他DNA序列中不需要像BF算法那样一个个好,然后回溯,因为cstring头文件里面有一个神器 strstr。。这回真是开了眼界了。。。


题目:

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12149   Accepted: 5266

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source


代码为:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int len=60;

char DNA[10+10][len+1];
char ans[len+1],Copy[len+1];
int ans_length,length;

int main()
{
    int t,n,pd,flag,i,j,k,count;
    scanf("%d",&t);
    while(t--)
    {
        count=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%s",DNA[i]);
        ans_length=-1;
        length=1;
        for(i=0;;i++)
        {
            flag=1;
            pd=i;
            if(pd+length>len)//判断序列是否越界
            {
                length++;
                i=-1;
                if(length>len)
                    break;
                continue;
            }
            for(j=0;j<length;j++)
                Copy[j]=DNA[1][pd++];
            Copy[j]='\0';
            for(k=2;k<=n;k++)
            {
                if(!strstr(DNA[k],Copy))//str函数是c语言自带的一个函数,意思是Copy数组是否在DNA[K]中出现过,其实这个可以用kmp来判断,但是我们有这么方便的函数,和乐而不为呢??
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
            {
                if(length==ans_length)
                {
                    if(strcmp(ans,Copy)>0)
                        strcpy(ans,Copy);
                }
                if(length>ans_length)
                {
                    ans_length=length;
                    strcpy(ans,Copy);
                }
            }
        }
        if(ans_length<3)
            printf("no significant commonalities\n");
        else
            printf("%s\n",ans);
    }
    return 0;
}



poj3080Blue Jeans,布布扣,bubuko.com

poj3080Blue Jeans

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://blog.csdn.net/u014303647/article/details/38448375

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!