码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1775 Sum of Factorials

时间:2016-08-18 17:18:14      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Description

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944). 
There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum of some factorials. 
Well, it‘s just a piece of cake. For a given n, you‘ll check if there are some xi, and let n equal to Σ 1<=i<=ti!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say "YES"; otherwise, print out "NO".

Input

You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself. 
The input is terminated by a line with a negative integer.

Output

For each n, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.

Sample Input

9
-1

Sample Output

YES

这个题目是考1个性质:

当n>1时,0!+1!+2!+......+n!<(n+1)!,当n=1时,0!+1!=2!,当n=0时,0!=1!

任取一个递增的函数f(x)满足下述条件:当x为整数时,f(x)=x!

用g表示f的反函数,那么这个算法的时间复杂度为θ(g(n))

比如说,本题n约为10!,那么大约有10次运算

(我这个描述其实是不准确的,因为有常数的问题。

准确的说法应该是,这个算法有大约g(n)次运算,常数为1)

代码:

#include<iostream>
using namespace std;

int fac[10] = { 1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880 };

int main()
{
	int n;
	while (cin >> n)
	{
		if (n < 0)break;
		if (n == 0)cout << "NO";
		else
		{
			for (int i = 9; i >= 0; i--)if (n>=fac[i])n -= fac[i];
			if (n == 0)cout << "YES";
			else cout << "NO";
		}
		cout << endl;
	}
	return 0;
}

POJ 1775 Sum of Factorials

标签:

原文地址:http://blog.csdn.net/nameofcsdn/article/details/52242194

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!