码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2828(线段树单点更新)

时间:2016-08-19 00:40:06      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 18561   Accepted: 9209

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

技术分享

Source

 
题意:当前有n个人要排队,第 i 个人来的时候插队的位置是他的前面有 k 个人,其价值是v[i].问最终排队的顺序,按照人的价值输出。
题解:想到线段树这题就不难了,逆序插入人数,假设当前的人的前面有 k 个人,那么就到线段树里面去找第k+1个没有被占的位置,画个图模拟一下这个过程就行了,然后通过一个数组记录下线段树每个叶子结点的value,输出即可。
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#define N 250005
using namespace std;

int tree[N<<2]; ///当前结点剩余的容量
int a[N],v[N],ans[N];
void pushup(int idx){
    tree[idx] = tree[idx<<1]+tree[idx<<1|1];
}
void build(int l,int r,int idx){
    if(l==r){
        tree[idx] = 1;
        return;
    }
    int mid = (l+r)>>1;
    build(l,mid,idx<<1);
    build(mid+1,r,idx<<1|1);
    pushup(idx);
}
void update(int num,int v,int l,int r,int idx){
    if(l==r){
        tree[idx]= 0;
        ans[l] = v;
        return;
    }
    int mid = (l+r)>>1;
    if(tree[idx<<1]>=num){ ///左子树还有位置可以插
        update(num,v,l,mid,idx<<1);
    }else{  ///往右子树插
        update(num-tree[idx<<1],v,mid+1,r,idx<<1|1);
    }
    pushup(idx);
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        build(1,n,1);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a[i],&v[i]);
            a[i]++;
        }
        for(int i=n;i>=1;i--){
            update(a[i],v[i],1,n,1);
        }
        for(int i=1;i<=n;i++){
            printf("%d ",ans[i]);
        }
        printf("\n");
    }
    return 0;
}

 

poj 2828(线段树单点更新)

标签:

原文地址:http://www.cnblogs.com/liyinggang/p/5785876.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!