码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1042 N!

时间:2016-08-19 15:10:27      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 75324    Accepted Submission(s): 21992


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

 

Input
One N in one line, process to the end of file.
 

 

Output
For each N, output N! in one line.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
2
6
 

 

Author
JGShining(极光炫影)
 
 
 
解析:大数。
 
 
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    static BigInteger fact(int n){
        BigInteger ret = BigInteger.ONE;
        for(int i = 1; i <= n; ++i){
            ret = ret.multiply(BigInteger.valueOf(i));
        }
        return ret;
    }
    public static void main(String[] args){
        Scanner in = new Scanner(System.in);
        int n;
        while(in.hasNext()){
        	n = in.nextInt();
            System.out.println(fact(n));
        }
        in.close();
    }
}

  

HDU 1042 N!

标签:

原文地址:http://www.cnblogs.com/inmoonlight/p/5787437.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!