码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu)2444 The Accomodation of Students 判断二分图+最大匹配数

时间:2016-08-20 11:29:56      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=2444

Problem Description
There are a group of students. Some of them may know each other, while others dont. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group dont know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
 

Sample Output
No
3

题意:有n个学生,a与b认识,b与c认识,但a与c不认识,问把学生分到两个房间,使每个房间的人都不认识,一个房间最多多少人?

方法:先判断是否能成二分图 不能输出No,能求最大匹配数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
using namespace std;
#define N 609
#define ll long long
#define INF 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof(a));
vector<vector<int> >Q;
int Map[N][N],vis[N],used[N],cl[N];
int n;
int dfs()
{
    int cot;
    met(cl,-1);
    queue<int> Q;
    Q.push(1);
    cl[1]=1;
    while(Q.size())
    {
        cot=Q.front();
        Q.pop();
        for(int i=1;i<=n;i++)
        {
            if(Map[cot][i])
            {
                if(cl[i]==-1)
                {
                    cl[i]=1-cl[cot];
                    Q.push(i);

                }
                else if(cl[i]==cl[cot])
                    return 0;
            }
        }
    }
    return 1;
}
int han(int u)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i] && Map[u][i])
        {
            vis[i]=1;
            if(!used[i] || han(used[i]))
                {
                    used[i]=u;
                    return 1;
                }
        }
    }
    return 0;
}
int main()
{
    int t,m,a,b;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        met(Map,0);

        for(int i=0;i<m;i++)
        {
            scanf("%d %d",&a,&b);
            Map[a][b]=Map[b][a]=1;
        }
        if(dfs()==0)///判断是否能成二分图
        {
            printf("No\n");
            continue;
        }
        else
        {
            int sum=0;met(used,0);
            for(int i=1;i<=n;i++)
            {
                met(vis,0);
                sum+=han(i);
            }

            printf("%d\n",sum/2);
        }
    }
    return 0;
}

 

(hdu)2444 The Accomodation of Students 判断二分图+最大匹配数

标签:

原文地址:http://www.cnblogs.com/jun939026567/p/5789965.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!