码迷,mamicode.com
首页 > 其他好文 > 详细

A water problem 大整数取模

时间:2016-08-20 13:04:03      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5814    Accepted Submission(s): 1238


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

 

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0N), the length of N is up to 10000000.
 

 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

 

Sample Input
10001 0 333
 

 

Sample Output
Case #1: YES Case #2: YES Case #3: NO
 
 
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1e8+5;
char s[maxn];
int ans,c;

int main(){
    while(~scanf("%s",s)){
        ans=0;
        int len=strlen(s);
        for(int i=0;i<len;i++)
            ans=(ans*10+s[i]-0)%10001;
        if(!ans){
            printf("Case #%d: YES\n",++c);
        }
        else printf("Case #%d: NO\n",++c);
    }

}

 

 

Statistic | Submit | Clarifications | Back

A water problem 大整数取模

标签:

原文地址:http://www.cnblogs.com/acmtime/p/5790024.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!