码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 5 Binary String Matching【string find的运用】

时间:2016-08-20 16:26:26      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0
3 
来源
网络

原题链接:http://acm.nyist.net/JudgeOnline/problem.php?pid=5

输入两个字符串,问你第二个字符串在第一个中出现了多少次,可重叠。

使用string 的find

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
string a,b;
int main()
{
    int T;
    //freopen("data/5.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>a>>b;
        int cnt=0;
        //for (int index=0; (index=b.find(a,index))!=string::npos; index += 1,cnt++);

        int index=0;
        while((index=b.find(a,index))!=string::npos)
        {
            index++;
            cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}




NYOJ 5 Binary String Matching【string find的运用】

标签:

原文地址:http://blog.csdn.net/hurmishine/article/details/52261820

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!