标签:des style http color java os io strong
Flyer
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1537 Accepted Submission(s): 552
Problem Description
The new semester begins! Different kinds of student societies are all trying to advertise themselves, by giving flyers to the students for introducing the society. However, due to the fund shortage, the flyers of a society can only be distributed to a part
of the students. There are too many, too many students in our university, labeled from 1 to 2^32. And there are totally N student societies, where the i-th society will deliver flyers to the students with label A_i, A_i+C_i,A_i+2*C_i,…A_i+k*C_i (A_i+k*C_i<=B_i,
A_i+(k+1)*C_i>B_i). We call a student "unlucky" if he/she gets odd pieces of flyers. Unfortunately, not everyone is lucky. Yet, no worries; there is at most one student who is unlucky. Could you help us find out who the unfortunate dude (if any) is? So that
we can comfort him by treating him to a big meal!
Input
There are multiple test cases. For each test case, the first line contains a number N (0 < N <= 20000) indicating the number of societies. Then for each of the following N lines, there are three non-negative integers A_i, B_i, C_i (smaller than 2^31, A_i <=
B_i) as stated above. Your program should proceed to the end of the file.
Output
For each test case, if there is no unlucky student, print "DC Qiang is unhappy." (excluding the quotation mark), in a single line. Otherwise print two integers, i.e., the label of the unlucky student and the number of flyers he/she gets, in a single line.
Sample Input
2
1 10 1
2 10 1
4
5 20 7
6 14 3
5 9 1
7 21 12
Sample Output
Source
二分查找,且要用64位整型,先统计标签数目,为偶数则必然不存在任何一个人为奇数的情况。
然后,在用二分查找。
#include"stdio.h"
#include"string.h"
#include"iostream"
using namespace std;
#define N 20005
#define inf 0x7fffffff
#define LL __int64
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
LL a[N],b[N],d[N];
int main()
{
int i,n;
while(~scanf("%d",&n))
{
LL sum,l,r,t;
sum=r=0; l=inf;
for(i=0;i<n;i++)
{
scanf("%I64d%I64d%I64d",&a[i],&b[i],&d[i]);
t=(b[i]-a[i])/d[i];
sum+=t+1;
r=max(r,a[i]+t*d[i]);
l=min(l,a[i]);
}
if(sum%2==0)
printf("DC Qiang is unhappy.\n");
else
{
LL mid,num,y;
while(l<=r)
{
mid=(l+r)/2;
num=0;
sum=0;
for(i=0;i<n;i++)
{
if(a[i]>mid)
continue;
if(mid<=b[i])
t=(mid-a[i])/d[i];
else if(mid>b[i])
t=(b[i]-a[i])/d[i];
sum+=t+1;
if(a[i]+t*d[i]==mid||mid==a[i]) //统计边界点mid的数目
num++;
y=mid;
}
if(num%2) break; //该点就是奇数点
if(sum%2) r=mid-1;
else l=mid+1;
}
printf("%I64d %I64d\n",y,num);
}
}
return 0;
}
hdu 4768 Flyer(二分查找),布布扣,bubuko.com
hdu 4768 Flyer(二分查找)
标签:des style http color java os io strong
原文地址:http://blog.csdn.net/u011721440/article/details/38455079