码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3122

时间:2014-08-09 15:53:58      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   

Pie
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10309   Accepted: 3651   Special Judge

Description

bubuko.com,布布扣My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

Northwestern Europe 2006


AC代码:

#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
double pi=3.14159265359;   //精度要足够大啊,要不wa死了
double v[10010];
int n,m;
double s,vm;
int judge(double mid){
    int sum=0;
    for(int i=1;i<=n;i++)
        sum+=(int)(v[i]/mid);
    if(sum>=m)
        return 1;
    return 0;
}
int main(){
    int T; scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        s=0.0; m++;
        for(int i=1;i<=n;i++){
            double r; scanf("%lf",&r);
            v[i]=pi*r*r;
            s+=v[i];
        }
        vm=s/(m+0.0);
        double left,right,mid;
        left=0.0; right=vm;
        while((right-left)>0.000001){
            mid=(right+left)/2;
            if(judge(mid))
                left=mid;
            else
                right=mid;
        }
        printf("%.4lf\n",left);
    }
    return 0;
}


poj 3122,布布扣,bubuko.com

poj 3122

标签:des   style   http   color   os   io   strong   for   

原文地址:http://blog.csdn.net/my_acm/article/details/38457257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!