标签:
Key Set
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1886 Accepted Submission(s): 990
Problem Description
soda has a set S with n integers {1,2,…,n}.
A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are
key set.
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤105),
indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤109),
the number of integers in the set.
Output
For each test case, output the number of key sets modulo 1000000007.
Sample Input
Sample Output
Author
zimpha@zju
Source
Recommend
wange2014
题意:给你一个具有n个元素的集合S{1,2,…,n},问集合S的非空子集中元素和为偶数的非空子集有多少个。
放入出题人的解题报告
解题思路:因为集合S中的元素是从1开始的连续的自然数,所以所有元素中奇数个数与偶数个数相同,或比偶数多一个。另外我们要知道偶数+偶数=偶数,奇数+奇数=偶数,假设现在有a个偶数,b个奇数,则
根据二项式展开公式
以及二项式展开式中奇数项系数之和等于偶数项系数之和的定理
可以得到上式
最后的结果还需减去
即空集的情况,因为题目要求非空子集
所以最终结果为
由于n很大,所以计算n次方的时候需要用到快速幂,不然会TLE
找到规律那就快速幂取模吧。
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1000000007;
typedef long long LL;
LL quick_mod(int a,int b)
{
// a^b%mod
LL ans=1;
LL t=a%mod;
while(b)
{
if(b&1)
ans=ans*t%mod;
t=t*t%mod;
b>>=1;
}
return ans;
}
int main()
{
int T;
cin>>T;
LL n;
while(T--)
{
cin>>n;
cout<<quick_mod(2,n-1)-1<<endl;
}
return 0;
}
HDU 5363 Key Set【快速幂取模】
标签:
原文地址:http://blog.csdn.net/hurmishine/article/details/52291235