码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2602 Bone Collector(01背包)

时间:2014-08-09 18:47:28      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:acm   dp   hdu   01背包   

Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
bubuko.com,布布扣

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14

裸的01背包啦啦啦啦

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1005;
int n, v, d[N], val[N], vol[N], cas;
int main()
{
    scanf ("%d", &cas);
    while (cas--)
    {
        memset (d, 0, sizeof (d));
        scanf ("%d%d", &n, &v);
        for (int i = 1; i <= n; ++i)
            scanf ("%d", &val[i]);
        for (int i = 1; i <= n; ++i)
        {
            scanf ("%d", &vol[i]);
            for (int j = v; j >= vol[i]; --j)
                d[j] = max (d[j], d[j - vol[i]] + val[i]);
        }
        printf ("%d\n", d[v]);
    }
    return 0;
}


HDU 2602 Bone Collector(01背包),布布扣,bubuko.com

HDU 2602 Bone Collector(01背包)

标签:acm   dp   hdu   01背包   

原文地址:http://blog.csdn.net/iooden/article/details/38458115

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!