码迷,mamicode.com
首页 > 其他好文 > 详细

题目1461:Tempter of the bone

时间:2016-08-26 22:41:29      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:

题目1461:Tempter of the bone

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:2079

解决:719

题目描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.
The input is terminated with three 0‘s. This test case is not to be processed. 

输出:

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

样例输入:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
样例输出:
NO
YES
提示:

 用scanf读取输入。

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;

char maze[8][8];//保存地图信息
int n,m,t;//地图大小为n*m,从起点到终点能否恰好t秒
bool success;//是否找打所需状态标记

int go[][2]=
{
    {1,0,},
    {-1,0},
    {0,1},
    {0,-1}
};
void DFS(int x,int y,int time)
{
    for(int i=0; i<4; i++)
    {
        int nx=x+go[i][0];
        int ny=y+go[i][1];
        if(nx<1||nx>n||ny<1||ny>m) continue;
        if(maze[nx][ny]==X) continue;//若该位置为墙,则跳过
        if(maze[nx][ny]==D)//若该位置为门
        {
            if(time+1==t)
            {
                success=true;//搜索成功
                return ;//返回
            }
            else continue;//否则该状态的后续状态不可能为答案(经过的点不能再经过),跳过
        }
        maze[nx][ny]=X;//该状态扩展而来的后续状态中,连位置都不能被经过,直接修改该位置为墙
        DFS(nx,ny,time+1);
        maze[nx][ny]=.;//其后续状态全部遍历完毕,则退回上层状态,将因为要搜索其后续状态而改成墙的位置,改回普通位置
        if(success) return;//假如已经成功,则直接返回,停止搜索
    }
}



int main()
{
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)
    {
        if(n==0&&m==0&&t==0) break;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",maze[i]+1);
        }//输入
        success =false;
        int sx,sy;
        for(int i=1; i<=n; i++) //寻找D的位置坐标
            for(int j=1; j<=m; j++)
            {
                if(maze[i][j]==D)
                {
                    sx=i;
                    sy=j;
                }
            }
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                //找到S点后,先判断S与D的奇偶性关系,是否和t符合,即符合上式,若不符合直接跳过搜索
                if(maze[i][j]==S&&(i+j)%2==((sx+sy)%2+t%2)%2)
                {
                    maze[i][j]=X;
                    DFS(i,j,0);
                }
            }
            puts(success==true?"YES":"NO");//若success为真,则输出yes
    }
    return 0;
}

 

题目1461:Tempter of the bone

标签:

原文地址:http://www.cnblogs.com/zhuoyuezai/p/5811818.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!