码迷,mamicode.com
首页 > 其他好文 > 详细

CCF 201312-5 I’m stuck! (暴力,BFS)

时间:2016-08-28 01:00:51      阅读:314      评论:0      收藏:0      [点我收藏+]

标签:

问题描述
  给定一个R行C列的地图,地图的每一个方格可能是‘#‘, ‘+‘, ‘-‘, ‘|‘, ‘.‘, ‘S‘, ‘T‘七个字符中的一个,分别表示如下意思:
  ‘#‘: 任何时候玩家都不能移动到此方格;
  ‘+‘: 当玩家到达这一方格后,下一步可以向上下左右四个方向相邻的任意一个非‘#‘方格移动一格;
  ‘-‘: 当玩家到达这一方格后,下一步可以向左右两个方向相邻的一个非‘#‘方格移动一格;
  ‘|‘: 当玩家到达这一方格后,下一步可以向上下两个方向相邻的一个非‘#‘方格移动一格;
  ‘.‘: 当玩家到达这一方格后,下一步只能向下移动一格。如果下面相邻的方格为‘#‘,则玩家不能再移动;
  ‘S‘: 玩家的初始位置,地图中只会有一个初始位置。玩家到达这一方格后,下一步可以向上下左右四个方向相邻的任意一个非‘#‘方格移动一格;
  ‘T‘: 玩家的目标位置,地图中只会有一个目标位置。玩家到达这一方格后,可以选择完成任务,也可以选择不完成任务继续移动。如果继续移动下一步可以向上下左右四个方向相邻的任意一个非‘#‘方格移动一格。
  此外,玩家不能移动出地图。
  请找出满足下面两个性质的方格个数:
  1. 玩家可以从初始位置移动到此方格;
  2. 玩家不可以从此方格移动到目标位置。
输入格式
  输入的第一行包括两个整数R 和C,分别表示地图的行和列数。(1 ≤ R, C ≤ 50)。
  接下来的R行每行都包含C个字符。它们表示地图的格子。地图上恰好有一个‘S‘和一个‘T‘。
输出格式
  如果玩家在初始位置就已经不能到达终点了,就输出“I‘m stuck!”(不含双引号)。否则的话,输出满足性质的方格的个数。
样例输入
5 5
--+-+
..|#.
..|##
S-+-T
####.
样例输出
2
 
析:直接用BFS进行两次暴力即可,第一次是搜索S能到哪些点,第二次是在第一次的基础上再搜这些点能不能到T。很简单。
代码如下:
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#define frer freopen("in.txt", "r", stdin)
#define frew freopen("out.txt", "w", stdout)
using namespace std;

typedef long long LL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const double inf = 0x3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 50 + 5;
const int mod = 1e9 + 7;
const int dr[] = {-1, 1, 0, 0};
const int dc[] = {0, 0, 1, -1};
const char *de[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline int Min(int a, int b){ return a < b ? a : b; }
inline int Max(int a, int b){ return a > b ? a : b; }
inline LL Min(LL a, LL b){ return a < b ? a : b; }
inline LL Max(LL a, LL b){ return a > b ? a : b; }
inline bool is_in(int r, int c){
    return r >= 0 && r < n && c >= 0 && c < m;
}
char s[maxn][maxn];
int vis[maxn][maxn];
int viss[maxn][maxn];

void bfs1(int x, int y){
    queue<P> q;
    q.push(P(x, y));
    vis[x][y] = 1;
    while(!q.empty()){
        P u = q.front();   q.pop();
        int x = u.first, y = u.second;
        for(int i = 0; i < 4; ++i){
            int xx = x + dr[i];
            int yy = y + dc[i];
            if(!is_in(xx, yy) || vis[xx][yy] || s[xx][yy] == ‘#‘)  continue;
            if(s[x][y] == ‘-‘ && (0 == i || 1 == i))  continue;
            if(s[x][y] == ‘|‘ && (2 == i || 3 == i))  continue;
            if(s[x][y] == ‘.‘ && (0 == i || 2 == i || 3 == i))  continue;
            vis[xx][yy] = 1;
            q.push(P(xx, yy));
        }
    }
}

bool bfs(int x, int y){
    queue<P> q;
    q.push(P(x, y));
    memset(viss, 0, sizeof viss);
    viss[x][y] = 1;
    while(!q.empty()){
        P u = q.front();   q.pop();
        int x = u.first, y = u.second;
        if(s[x][y] == ‘T‘)  return false;
        for(int i = 0; i < 4; ++i){
            int xx = x + dr[i];
            int yy = y + dc[i];
            if(!is_in(xx, yy) || s[xx][yy] == ‘#‘ || viss[xx][yy])  continue;
            if(s[x][y] == ‘-‘ && (0 == i || 1 == i))  continue;
            if(s[x][y] == ‘|‘ && (2 == i || 3 == i))  continue;
            if(s[x][y] == ‘.‘ && (0 == i || 2 == i || 3 == i))  continue;
            viss[xx][yy] = 1;
            q.push(P(xx, yy));
        }
    }
    return true;
}

int main(){
    scanf("%d %d", &n, &m);
    for(int i = 0; i < n; ++i)  scanf("%s", s[i]);
    memset(vis, 0, sizeof vis);
    int sx, sy, tx, ty;
    for(int i = 0; i < n; ++i){
        for(int j = 0; j < m; ++j){
            if(s[i][j] == ‘S‘)  sx = i, sy = j;
            else if(s[i][j] == ‘T‘)   tx = i, ty = j;
        }
    }
    bfs1(sx, sy);
    if(!vis[tx][ty]) {  puts("I‘m stuck!");  return 0; }
    int ans = 0;
    for(int i = 0; i < n; ++i){
        for(int j = 0; j < m; ++j){
            if(vis[i][j] == 1 && bfs(i, j))  ++ans;
        }
    }

    printf("%d\n", ans);
    return 0;
}

 

CCF 201312-5 I’m stuck! (暴力,BFS)

标签:

原文地址:http://www.cnblogs.com/dwtfukgv/p/5814082.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!