码迷,mamicode.com
首页 > 其他好文 > 详细

Martian Mining_DP&&DFS

时间:2016-08-28 22:32:53      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 2567   Accepted: 1595

Description

The NASA Space Center, Houston, is less than 200 miles from San Antonio, Texas (the site of the ACM Finals this year). This is the place where the astronauts are trained for Mission Seven Dwarfs, the next giant leap in space exploration. The Mars Odyssey program revealed that the surface of Mars is very rich in yeyenum and bloggium. These minerals are important ingredients for certain revolutionary new medicines, but they are extremely rare on Earth. The aim of Mission Seven Dwarfs is to mine these minerals on Mars and bring them back to Earth. 

The Mars Odyssey orbiter identified a rectangular area on the surface of Mars that is rich in minerals. The area is divided into cells that form a matrix of n rows and m columns, where the rows go from east to west and the columns go from north to south. The orbiter determined the amount of yeyenum and bloggium in each cell. The astronauts will build a yeyenum refinement factory west of the rectangular area and a bloggium factory to the north. Your task is to design the conveyor belt system that will allow them to mine the largest amount of minerals. 

There are two types of conveyor belts: the first moves minerals from east to west, the second moves minerals from south to north. In each cell you can build either type of conveyor belt, but you cannot build both of them in the same cell. If two conveyor belts of the same type are next to each other, then they can be connected. For example, the bloggium mined at a cell can be transported to the bloggium refinement factory via a series of south-north conveyor belts. 

The minerals are very unstable, thus they have to be brought to the factories on a straight path without any turns. This means that if there is a south-north conveyor belt in a cell, but the cell north of it contains an east-west conveyor belt, then any mineral transported on the south-north conveyor beltwill be lost. The minerals mined in a particular cell have to be put on a conveyor belt immediately, in the same cell (thus they cannot start the transportation in an adjacent cell). Furthermore, any bloggium transported to the yeyenum refinement factory will be lost, and vice versa. 
技术分享 
Your program has to design a conveyor belt system that maximizes the total amount of minerals mined,i.e., the sum of the amount of yeyenum transported to the yeyenum refinery and the amount of bloggium transported to the bloggium refinery.

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 500 of rows, and the number 1 ≤ m ≤ 500 of columns. The next n lines describe the amount of yeyenum that can be found in the cells. Each of these n lines contains m integers. The first line corresponds to the northernmost row; the first integer of each line corresponds to the westernmost cell of the row. The integers are between 0 and 1000. The next n lines describe in a similar fashion theamount of bloggium found in the cells. 

The input is terminated by a block with n = m = 0.

Output

For each test case, you have to output a single integer on a separate line: the maximum amount of mineralsthat can be mined.

Sample Input

4 4
0 0 10 9
1 3 10 0
4 2 1 3 
1 1 20 0
10 0 0 0
1 1 1 30
0 0 5 5
5 10 10 10
0 0

Sample Output

98

Hint

Huge input file, ‘scanf‘ recommended to avoid TLE. 

 

 

 

 

 

【题意】有两种矿物,Y和B,矩形区域内每格给出了两种东西的数量,其中B要运到上面的仓库,Y要运到左面的仓库,必须沿直线,每格只能有一种方向的运输,求最大能到达仓库的数量之和

从右下角开始dp[i][j]=max(dp[i-1][j]+sum1,dp[i][j-1]+sum2)

sum1=SUM(a[i][1~j]),sum2=SUM(b[1~i][j])

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=505;
int dp[N][N],a[N][N],b[N][N];
int dfs(int i,int j)
{
    if(i<1||j<1) return 0;
    if(dp[i][j]!=-1) return dp[i][j];
    int sum1=0,sum2=0;
    for(int h=1;h<=j;h++)
        sum1+=a[i][h];
    for(int h=1;h<=i;h++)
        sum2+=b[h][j];
    dp[i][j]=max(dfs(i-1,j)+sum1,dfs(i,j-1)+sum2);
    return dp[i][j];
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m),n||m)
    {
        memset(dp,-1,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&b[i][j]);
            }
        }
        int ans=dfs(n,m);
        printf("%d\n",ans);

    }
    return 0;
}

 

Martian Mining_DP&&DFS

标签:

原文地址:http://www.cnblogs.com/iwantstrong/p/5816005.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!