码迷,mamicode.com
首页 > 其他好文 > 详细

01背包

时间:2014-08-10 13:10:20      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

原题http://acm.hdu.edu.cn/showproblem.php?pid=2546

饭卡

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11331    Accepted Submission(s): 3895


Problem Description
电子科大本部食堂的饭卡有一种很诡异的设计,即在购买之前判断余额。如果购买一个商品之前,卡上的剩余金额大于或等于5元,就一定可以购买成功(即使购买后卡上余额为负),否则无法购买(即使金额足够)。所以大家都希望尽量使卡上的余额最少。
某天,食堂中有n种菜出售,每种菜可购买一次。已知每种菜的价格以及卡上的余额,问最少可使卡上的余额为多少。


 

Input
多组数据。对于每组数据:
第一行为正整数n,表示菜的数量。n<=1000。
第二行包括n个正整数,表示每种菜的价格。价格不超过50。
第三行包括一个正整数m,表示卡上的余额。m<=1000。

n=0表示数据结束。


 

Output
对于每组输入,输出一行,包含一个整数,表示卡上可能的最小余额。


 

Sample Input
1 50 5 10 1 2 3 2 1 1 2 3 2 1 50 0


 

Sample Output
-45 32
//一道很水的01背包,状态转移方程为dp[j] = max(dp[j],dp[j-cost[i]]+cost[i]);
//但在处理之前要先把5拿出来处理掉。。。
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define N 1000 + 10
int dp[N];
int cost[N];

int max(int a,int b){
	return a>b?a:b;
}

int main(){
	int n,i,m;
	
	while(~scanf("%d",&n)){
		if(n == 0){
			break;
		}
		memset(dp,0,sizeof(dp));
		memset(cost,0,sizeof(cost));
		for(i=1;i<=n;i++){
			scanf("%d",&cost[i]);
		}
		sort(cost,cost+n+1);
		scanf("%d",&m);
		int j;
		if(m >= 5){	
			for(i=1;i<=n-1;i++){
				for(j=m-5;j>=cost[i];j--){
					dp[j] = max(dp[j],dp[j-cost[i]]+cost[i]);
				}
			}
			printf("%d\n",m-cost[n]-dp[m-5]);
		}
		else{
			printf("%d\n",m);
		}
		//printf("%d\n",m-dp[m]);
	}
	
	return 0;
}


 

01背包,布布扣,bubuko.com

01背包

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/zcr_7/article/details/38467079

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!