标签:
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 46858 |
|
Accepted: 24819 |
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
【题意】 给出一个n*n的方阵,选出一个子矩阵使得里面的值相加最大
【思路】先不管上下,先看左右,找出值最大的j列到k列,然后确定了以后,就好似成了一列,对这列上下求最大子段和
dp[i][j][k]=max(dp[i-1][j][k]+tmp,tmp);tmp=第i行j到k列的值之和
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int inf=0x7777777;
const int N=107;
int a[N][N];
int dp[N][N][N];
int main()
{
int n;
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
{
scanf("%d",&a[i][j]);
}
}
int ans=-inf;
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
{
int tmp=0;
for(int k=j; k<=n; k++)
{
tmp+=a[i][k];
dp[i][j][k]=max(dp[i-1][j][k]+tmp,tmp);
if(dp[i][j][k]>ans)
ans=dp[i][j][k];
}
}
}
printf("%d\n",ans);
}
return 0;
}
To the Max_DP
标签:
原文地址:http://www.cnblogs.com/iwantstrong/p/5820931.html