码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1426 <Find The Multiple> <搜索>

时间:2016-08-30 17:33:09      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111


 

题解:首先,题目没有提示,也就是最后答案肯定不需要大数模板,也就是long long存的下,那就是18位的10进制数够了。直接暴力跑一遍就行。

 

#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool found;
 void DFS(unsigned long long t, int n, int k)
 {
     if (found)
         return;
   if (t%n == 0)
     {
         printf("%I64u\n", t);
         found = true;
         return;
     }
   if (k == 19)
         return;
     DFS(t * 10, n, k + 1);  
     DFS(t * 10 + 1, n, k + 1);   
 }
 int main()
 {
     int n;
     while (scanf("%d",&n)&&n)
     {
         found = false;
         DFS(1, n, 0);
     }
     return 0;
 }

 

POJ 1426 <Find The Multiple> <搜索>

标签:

原文地址:http://www.cnblogs.com/914295860-jry/p/5822537.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!