码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj 107

时间:2014-08-10 15:44:00      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:南阳oj   排序   

A Famous ICPC Team

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述

Mr. B, Mr. G, Mr. M and their coach Professor S are planning their way to Warsaw for the ACM-ICPC World Finals. Each of the four has a square-shaped suitcase with side length Ai (1<=i<=4) respectively. They want to pack their suitcases into a large square box. The heights of the large box as well as the four suitcases are exactly the same. So they only need to consider the large box’s side length. Of course, you should write a program to output the minimum side length of the large box, so that the four suitcases can be put into the box without overlapping.

输入
Each test case contains only one line containing 4 integers Ai (1<=i<=4, 1<=Ai<=1,000,000,000) indicating the side length of each suitcase.
输出
For each test case, display a single line containing the case number and the minimum side length of the large box required.
样例输入
2 2 2 2
2 2 2 1
样例输出
Case 1: 4
Case 2: 4
提示
For the first case, all suitcases have size 2x2. So they can perfectly be packed in 
a 4x4 large box without wasting any space.
For the second case, three suitcases have size 2x2 and the last one is 1x1. No
matter how you rotate or move the suitcases, the side length of the large box must
be at least 4.
来源
hdu
上传者

李如兵

题意:就是知道四个人的箱子的边长,并且每个箱子都是正方向的,要求找到一个最小尺寸的并且能够装得下四个箱子没有重叠的最小边长。

思路:就是将四个数据排序,然后将四个数据的前两个较大的数相加,就能都满足要求。

代码如下:

<span style="font-size:14px;"><strong>#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
	int a[4];
	int count=0;
	while(~scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]))
	{
		sort(a,a+4);
		printf("Case %d: %d\n",++count,a[3]+a[2]);
		memset(a,0,sizeof(a));
	}
	return 0;
}</strong></span>



nyoj 107,布布扣,bubuko.com

nyoj 107

标签:南阳oj   排序   

原文地址:http://blog.csdn.net/ice_alone/article/details/38470195

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!