码迷,mamicode.com
首页 > 其他好文 > 详细

uva 712 - S-Trees

时间:2014-08-10 18:11:00      阅读:415      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

 

  S-Trees 

A Strange Tree (S-tree) over the variable set bubuko.com,布布扣 is a binary tree representing a Boolean function bubuko.com,布布扣. Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree‘s nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables bubuko.com,布布扣 is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0‘s and 1‘s on terminal nodes are sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables bubuko.com,布布扣, then it is quite simple to find out what bubuko.com,布布扣 is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

 

bubuko.com,布布扣

 

Figure 1: S-trees for the function bubuko.com,布布扣

On the picture, two S-trees representing the same Boolean function, bubuko.com,布布扣, are shown. For the left tree, the variable ordering is x1, x2, x3, and for the right tree it is x3, x1, x2.

The values of the variables bubuko.com,布布扣, are given as a Variable Values Assignment (VVA)

bubuko.com,布布扣


with bubuko.com,布布扣. For instance, ( x1 = 1, x2 = 1 x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value bubuko.com,布布扣. The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes bubuko.com,布布扣 as described above.

 

Input 

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n, bubuko.com,布布扣, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1 xi2 ...xin. (There will be exactly n different space-separated strings). So, for n = 3 and the variable ordering x3, x1, x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0‘s and 1‘s over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

 

Output 

For each S-tree, output the line ``S-Tree #j:", where j is the number of the S-tree. Then print a line that contains the value of bubuko.com,布布扣 for each of the given m VVAs, where f is the function defined by the S-tree.

Output a blank line after each test case.

 

Sample Input 

 

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

 

Sample Output 

S-Tree #1:
0011

S-Tree #2:
0011
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>
#include <cmath>

using namespace std;
/*

*/
#define ms(arr, val) memset(arr, val, sizeof(arr))
#define N 10
#define INF 0x3fffffff
#define vint vector<int>
#define setint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
#define qch queue<char>
#define sint stack<int>
#define qint queue<int>

int stree[N];
char term[1000];
char vva[N];
/*
看懂了题目还是比较简单的。
给一个vva,找对应的叶子节点的值。
vva中0表示往左子树走,1表示在右子树找
例如:
题目中的right tree it is x3, x1, x2;
给的vva是1 1 0,也就是x3=0,x1=1,x2=2
那么找的话,就是先左再右再右就是答案1了
*/
int expo(int a, int n)//a^n
{
    int ans = 1;
    while (n)
    {
        if (n & 1)
        {
            ans *= a;
        }
        a *= a;
        n >>= 1;
    }
    return ans;
}
void bin_search(int i, int j, int p)//二分搜索
{
    if (i >= j)
    {
        putchar(term[j]);
        return;
    }
    if (vva[stree[p]] == 0)
        bin_search(i, (i + j) / 2, p + 1);
    else
        bin_search((i + j) / 2 + 1, j, p + 1);
}
int main()
{
    int n, len, i, m, cases = 1;
    string t;
    while (scanf("%d", &n), n)
    {
        i = 1;
        cin>>t;
        len = t.length() - 1;
        stree[i] = t[len] - 0;
        for (i++; i <= n; i++)
        {
            cin>>t;
            stree[i] = t[len] - 0;
        }
        len = expo(2, n);
        scanf("%s", term + 1);
        scanf("%d", &m);
        printf("S-Tree #%d:\n", cases++);
        while (m--)
        {
            scanf("%s", vva + 1);
            bin_search(1, len, 1);
        }
        printf("\n\n");
    }
    return 0;
}

 

uva 712 - S-Trees,布布扣,bubuko.com

uva 712 - S-Trees

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/jecyhw/p/3903020.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!