码迷,mamicode.com
首页 > 其他好文 > 详细

uva 540 - Team Queue

时间:2014-08-10 18:13:30      阅读:328      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

 

  Team Queue 

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

 


In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

 


Your task is to write a program that simulates such a team queue.

 

Input 

The input file will contain one or more test cases. Each test case begins with the number of teams t ( bubuko.com,布布扣). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

 

  • ENQUEUE x - enter element x into the team queue
  • DEQUEUE - process the first element and remove it from the queue
  • STOP - end of test case

The input will be terminated by a value of 0 for t.

 


Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

 

Output 

For each test case, first print a line saying ``Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

 

Sample Input 

 

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

 

Sample Output 

 

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>

using namespace std;

#define ms(arr, val) memset(arr, val, sizeof(arr))
#define N 1000000
#define INF 0x3fffffff
#define vint vector<int>
#define setint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
#define qch queue<char>
#define sint stack<int>
#define qint queue<int>

struct teamQueue 
{
    int l;//左边元素下标
    int r;//右边元素下标
    int t;//属于哪个队
}tq[N];

struct info//记对应每个队的在teamQueue中的信息
{
    int con;//个数
    int tail;//队尾
}re[1005];

struct tqInfo//记录teamQueue的信息
{
    int front;//对头
    int tail;//队尾
}tqi;

void enqueue(int val)//插入元素
{
    int t = tq[val].t;
    if (tqi.tail != -1)
    {
        if (re[t].con)//对应队列有元素在teamQueue
        {
            int tail = re[t].tail;
            tq[val].l = tail;
            tq[val].r = tq[tail].r;
            tq[tail].r = val;
            if (tqi.tail == tail)
            {
                tqi.tail = val;
            }
        }
        else
        {
            tq[val].l = tqi.tail;
            tq[tqi.tail].r = val;
            tqi.tail = val;
        }
    }
    else
        tqi.tail = tqi.front = val;
    re[t].con++;
    re[t].tail = val;
}

void dequeue()
{
    int front = tqi.front;
    printf("%d\n", front);
    re[tq[front].t].con--;
    tqi.front = tq[front].r;
    tq[front].l = tq[front].r = -1;
    if (tqi.front == -1)
    {
        tqi.tail = -1;
    }
}
int t;
char cmd[10];
int main()
{
    int tn, num, cases = 1;
    while (scanf("%d", &t), t)
    {
        for (int i = 1; i <= t; i++)
        {
            scanf("%d", &tn);
            while (tn--)
            {
                scanf("%d", &num);
                tq[num].t = i;
                tq[num].l = tq[num].r = -1;
            }
        }
        ms(re, 0);
        tqi.front = tqi.tail = -1;
        printf("Scenario #%d\n", cases++);
        while (scanf("%s", cmd), strcmp(cmd, "STOP") != 0)
        {
            if (cmd[0] == E)
            {
                scanf("%d", &num);
                enqueue(num);
            }
            else
                if (cmd[0] == D)
                {
                    dequeue();
                }
        }
        putchar(\n);
    }
    return 0;
}

 

uva 540 - Team Queue,布布扣,bubuko.com

uva 540 - Team Queue

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/jecyhw/p/3903001.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!