码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 3037 Saving Beans

时间:2014-08-10 18:38:50      阅读:293      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

假设有n+1个树,第n+1个树埋不足m的种子,隔板法C【n+m】【m】

大组合数取mod用Lucas定理:


Lucas(n,m,p) = C[n%p][m%p] × Lucas(n/p,m/p,p) ;


Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2314    Accepted Submission(s): 845


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
 

Output
You should output the answer modulo p.
 

Sample Input
2 1 2 5 2 1 5
 

Sample Output
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

LL n,m,p;

LL fact[100100];

LL QuickPow(LL x,LL t,LL m)
{
	if(t==0) return 1LL;
	LL e=x,ret=1LL;
	while(t)
	{
		if(t&1) ret=(ret*e)%m;
		e=(e*e)%m;
		t>>=1LL;
	}
	return ret%m;
}

void get_fact(LL p)
{
	fact[0]=1LL;
	for(int i=1;i<=p+10;i++)
		fact[i]=(fact[i-1]*i)%p;
}

LL Lucas(LL n,LL m,LL p)
{
	///lucas(n,m,p)=c[n%p][m%p]*lucas(n/p,m/p,p);
	LL ret=1LL;
	while(n&&m)
	{
		LL a=n%p,b=m%p;
		if(a<b) return 0;
		ret=(ret*fact[a]*QuickPow((fact[b]*fact[a-b])%p,p-2,p))%p;
		n/=p; m/=p;
	}
	return ret%p;
}

int main()
{
	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		LL n,m,p;
		cin>>n>>m>>p;
		get_fact(p);
		cout<<Lucas(n+m,m,p)<<endl;
	}
	return 0;
}



HDOJ 3037 Saving Beans,布布扣,bubuko.com

HDOJ 3037 Saving Beans

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/38471743

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!